Author Topic: PSFreedom in Openiboot - confirmed working with 3g and custom IOS 4.1  (Read 522 times)

Offline aa240sx

  • Member
  • Posts: 1
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: Openiboot
  • Jailbreak: redsnOw 0.9.6b5 win

Just wanted to let everyone know who has been patiently waiting for an unlock for their Iphone 3g on BB 05.14.02 that the new jailbreak method found on Dev Team Blog does work!

Why do I state something not related to this post? Because it sort of is related. Those that were using their Iphone 3g to jailbreak their PS3 using PSFreedom but not using it as a phone because it was locked can now use their Iphone as a phone again, but when you go through the Dev Team's instructions to unlock your phone you end up with a custom IOS 4.1.

This link shows step by step how to get PSFreedom back on your newly jailbroken and unlocked Iphone 3G, but I would like to share my experience in following the instructions found above.

1 - Using Windows, steps 12 and 13 seemed confusing to me, what is critical about these steps are that you first type OIBC in the command terminal, but do not hit enter. On the Iphone use the power button to select the 'console' icon, then wait 1 to 2 seconds and hit enter on the command terminal. That should allow you to successfully upload openiboot.img3.

2 - The other tricky part is at the final step after you've rebooted and succesfully installed Openiboot, you then have to follow the steps to add the two PSFreedom files to the phone. I found this youtube link from ChristechTV to be very helpful.

When you go to SSH your files to your Iphone, the Idroid directory located in /VAR will not exist, you will have to create it.

That's it. Hopefully this helps others.

« Last Edit: December 01, 2010, 07:00:29 PM by aa240sx »

Offline argirop

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version:
  • Jailbreak: Redsn0w 0.9.3
Re: PSFreedom in Openiboot - confirmed working with 3g and custom IOS 4.1
« Reply #1 on: December 14, 2010, 07:19:37 PM »
Have you tried to jailbreak your ps3 mate? My ps3 is not jailbroken (and downgraded it from 3.50 to 3.41 by following this tutorial which i found it a bit frustrating and had to experiment a lot cause a lot of things where incorrect) and each time i m trying to do so with my iphone 3g (3.1.2 firmware atm) i m getting the */app_home/PS3_GAME/ and the *install Package Files empty. I have tried so far various jailbreaks and all of them are ending in the same way- empty folders.... Anyways any kind of feedback or help would be appreciated.

                                                                                                                                      Thanks in advance.

P.S. My Iphone 3g (3.1.2 is jailbroken with Redsn0w, iboot was succesfuly installed with virtual Ubuntu 10.10, and iDroid's version is installed through cydia/bootlace since 1 shot installation of iDroid was keep on failing to connect with my phone on windows 7 and windows 7x64  >:(.