Author Topic: iX SHR 1.00 for 3G  (Read 2330 times)

Offline MusicManNick

  • Member
  • Posts: 6
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version: MoJo 1.0.5
  • Jailbreak: redsn0w 0.9.6b4
iX SHR 1.00 for 3G
« on: February 10, 2011, 01:36:25 AM »
So uh, I really wanna try out iX, it's really peaked my interest. I copied all the files over to their directories(Yes I read the README) but when I go to boot iX I get the error:
Quote
pivot_root: Device or resource busy
chroot: can't execute '/sbin/init': No such file or directory
kernel panic - not syncing: Attempted to kill init!

So what's the problem here?

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: iX SHR 1.00 for 3G
« Reply #1 on: February 11, 2011, 12:42:13 AM »
So uh, I really wanna try out iX, it's really peaked my interest. I copied all the files over to their directories(Yes I read the README) but when I go to boot iX I get the error:
Quote
pivot_root: Device or resource busy
chroot: can't execute '/sbin/init': No such file or directory
kernel panic - not syncing: Attempted to kill init!

So what's the problem here?

This could be quite a few different things. What device do you have?

Offline MusicManNick

  • Member
  • Posts: 6
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version: MoJo 1.0.5
  • Jailbreak: redsn0w 0.9.6b4
Re: iX SHR 1.00 for 3G
« Reply #2 on: February 11, 2011, 02:10:45 AM »
I've got an iPhone 3G

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: iX SHR 1.00 for 3G
« Reply #3 on: February 11, 2011, 06:52:05 PM »
I've got an iPhone 3G

Where did you place all the required files and what are their names? It sounds like you're not using the kernel I provided with release.

Offline MusicManNick

  • Member
  • Posts: 6
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version: MoJo 1.0.5
  • Jailbreak: redsn0w 0.9.6b4
Re: iX SHR 1.00 for 3G
« Reply #4 on: February 11, 2011, 09:15:31 PM »
I renamed initrd.img.gz to android.img.gz and put it in /var/idroid. I also put zImage in /var/idroid
Then I created the folder ix in the /var directory and put ix.img in there, then I tried to boot into iX using openiboot. It worked once, and I got to a screen with a cursor, a button that said English (US) and a next button, but the screen wasn't responding so I rebooted, went into Bootlace, and extracted the Multi-touch firmware, then booted it again, but the screen still didn't work. Then I rebooted it a third time and got the error message

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: iX SHR 1.00 for 3G
« Reply #5 on: February 11, 2011, 10:45:02 PM »
I renamed initrd.img.gz to android.img.gz and put it in /var/idroid. I also put zImage in /var/idroid
Then I created the folder ix in the /var directory and put ix.img in there, then I tried to boot into iX using openiboot. It worked once, and I got to a screen with a cursor, a button that said English (US) and a next button, but the screen wasn't responding so I rebooted, went into Bootlace, and extracted the Multi-touch firmware, then booted it again, but the screen still didn't work. Then I rebooted it a third time and got the error message

The files are corrupted. Delete all the files and copy them again. Make sure you have the following files in /var/firmware/
sd8686.bin
sd8686_helper.bin
zephyr2.bin
zephyr2_proxcal.bin
zephyr2_cal.bin

It's also possible the touch screen is now at a different location in the device tree. It's usually located at /dev/input/event2.

Offline MusicManNick

  • Member
  • Posts: 6
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version: MoJo 1.0.5
  • Jailbreak: redsn0w 0.9.6b4
Re: iX SHR 1.00 for 3G
« Reply #6 on: February 11, 2011, 11:44:41 PM »
I renamed initrd.img.gz to android.img.gz and put it in /var/idroid. I also put zImage in /var/idroid
Then I created the folder ix in the /var directory and put ix.img in there, then I tried to boot into iX using openiboot. It worked once, and I got to a screen with a cursor, a button that said English (US) and a next button, but the screen wasn't responding so I rebooted, went into Bootlace, and extracted the Multi-touch firmware, then booted it again, but the screen still didn't work. Then I rebooted it a third time and got the error message

The files are corrupted. Delete all the files and copy them again. Make sure you have the following files in /var/firmware/
sd8686.bin
sd8686_helper.bin
zephyr2.bin
zephyr2_proxcal.bin
zephyr2_cal.bin

It's also possible the touch screen is now at a different location in the device tree. It's usually located at /dev/input/event2.
I have sd8686.bin, sd8686_helper.bin, and zephyr2.bin. Where do I get zephyr2_proxcal.bin and zephyr2_cal.bin?

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: iX SHR 1.00 for 3G
« Reply #7 on: March 01, 2011, 12:13:05 AM »
I renamed initrd.img.gz to android.img.gz and put it in /var/idroid. I also put zImage in /var/idroid
Then I created the folder ix in the /var directory and put ix.img in there, then I tried to boot into iX using openiboot. It worked once, and I got to a screen with a cursor, a button that said English (US) and a next button, but the screen wasn't responding so I rebooted, went into Bootlace, and extracted the Multi-touch firmware, then booted it again, but the screen still didn't work. Then I rebooted it a third time and got the error message

The files are corrupted. Delete all the files and copy them again. Make sure you have the following files in /var/firmware/
sd8686.bin
sd8686_helper.bin
zephyr2.bin
zephyr2_proxcal.bin
zephyr2_cal.bin

It's also possible the touch screen is now at a different location in the device tree. It's usually located at /dev/input/event2.
I have sd8686.bin, sd8686_helper.bin, and zephyr2.bin. Where do I get zephyr2_proxcal.bin and zephyr2_cal.bin?

You shouldn't need them. I'm not sure why it's not booting. I apologize for the delayed response. What iOS verison are you running?