Author Topic: qemu arm and openiboot are no fernds :(  (Read 345 times)

Offline hotdog

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g,iphone 3gs,ipad 1(no screen)
  • iDroid Version: (none)
  • Jailbreak: PwnageTool,sn0wbreze
qemu arm and openiboot are no fernds :(
« on: May 05, 2012, 10:56:14 PM »
if i run a UNMODIFED version of qemu(qemu-system-arm) 0.14.50 and openiboot (only tested on x86(ubuntu linux)) you will get this error:

qemu: fatal: Unimplemented cp15 register read (c1, c0, {0, 1})

R00=0049187c R01=00f00000 R02=40000000 R03=00000800
R04=00000004 R05=00000000 R06=00000000 R07=00000000
R08=00000000 R09=00000000 R10=000376d8 R11=00000000
R12=00000000 R13=0fffbfe4 R14=000007d9 R15=000004d8
PSR=000001d3 ---- A svc32
Aborted


(i realy dont know wat its means this codes) but its help by make a ios emulator if somone knows wat is gooing wrong
and how to fix this(ps the ios emulator requred(later) a ORIGENAL APPLE ipsw of ios 5.0(no link because of copyrigts)
this is soo  >:( me
  :o  8) ??? ::) :P :-[ :-X :-\ :-* :'( >:( >:( ;D :D ;) :) !@#$%^&*()~@#$%^&*()(*()_+"|:? this

Offline hotdog

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g,iphone 3gs,ipad 1(no screen)
  • iDroid Version: (none)
  • Jailbreak: PwnageTool,sn0wbreze
Re: qemu arm and openiboot are no fernds :(
« Reply #1 on: May 06, 2012, 08:42:23 PM »
i get openiboot(almost) 100% working on iemu oly the controls and a error:

s5l8900_gpio_read: offset 0x000002c4

can somone say wat this means